リリースモードとデバッグモード

[戻る]
mua 2002/11/24(日) 23:42:14
win2000 MFC VC++6.0

皆さんにお聞きしたいのですが、
デバッグモードでビルドして、できた実行ファイルはうまく動くのですが、
リリースモードでビルドして、できた実行ファイルはエラーがでてきます。
メモリがreadになることはできませんでしたと出ます。(ダイナミックリンクの場合)

スタティックリンクの場合は逆で、
デバッグモードでは、エラーがでるのですが、
リリースモードでは、ビルドでエラーはでません。
しかし、ファイルへの出力結果がおかしくなります。
0に1を加えて1にしたいのに、4とか期待はずれの結果となります。

デバッグモードやリリースモード、ダイナミックやスタティックリンクを変更すると、
なぜ、エラーが出てきたり、実行結果が変わったりするのでしょうか。

YuO [E-Mail] 2002/11/25(月) 09:04:01
a.) 本来問題がある行為を行っているが,たまたまデバッグモード(or リリースモード)で動いている
b.) リリースモードの最適化の結果間違ったコードをコンパイラが吐きだした

のどちらかです。
まずはa.を疑ってみるのがよいでしょう。

こん! 2002/11/25(月) 10:34:51
 デバッグ時にのみ実行可能となるTRACE文の中に実際必要としているコーディングをして
しまっているとか。リリースビルド時にはそっくり消えてしまう。

こん!<=^・^=>

tib 2002/11/25(月) 11:13:16
.libと.dllでバージョンが一致していない、とか。

PAI 2002/11/25(月) 11:56:04
初期化してない変数の値に依存した部分がある、とか。

mua 2002/11/25(月) 18:03:44
> 0に1を加えて1にしたいのに、4とか期待はずれの結果となります。
この問題は
> 初期化してない変数の値に依存した部分がある、とか。
で解決できました。

ひとつ質問ですが、ビルドを行うとDebugやReleaseのフォルダが作成されますが、
その中に、exeの実行ファイルと.objや.idbなどの中間ファイルもあります。
これはビルドが正常に終了していないためでしょうか。
それとも、中間ファイルはフォルダ内に残ったままになるのでしょうか。

こん! 2002/11/25(月) 18:22:22
残ります。
じゃないと次にビルドする時にまた全てコンパイルしなければならなくなってしまうのでは?

こん!<=^・^=>

mua 2002/11/25(月) 19:04:37
warning LNK4098: defaultlib "MSVCRT" は他のライブラリの使用と競合しています;
/NODEFAULTLIB:library を使用してください

というようなエラーがでましたが、意味がわかりません。
どういうことなのでしょうか。
ライブラリを変更しろってことですか。
デバッグモードやリリースモード、ダイナミックやスタティックリンクを変更すると、
エラーがでるのは、このせいでしょうか。

こん! 2002/11/25(月) 20:27:53
> warning LNK4098: defaultlib "MSVCRT" は他のライブラリの使用と競合しています;
> /NODEFAULTLIB:library を使用してください

> というようなエラーがでましたが、意味がわかりません。
> どういうことなのでしょうか。

取り敢えずエラーじゃないですね。ワーニングです。
MSDNでLNK4098を検索して読んでみましょう。

こん!<=^・^=>

YuO [E-Mail] 2002/11/25(月) 20:55:06
標準のライブラリ以外のライブラリを使っているときは,
作成したライブラリに使用するCRTを合わせる必要が出てきます。

> /NODEFAULTLIB:library を使用してください
これは単なる対処療法ですから,根本から設定を変更した方がよいです。

こん! 2002/11/26(火) 00:27:36
> これは単なる対処療法ですから,根本から設定を変更した方がよいです。

 確かにその通りなのですがね。muaさんはいろいろ設定をいじりたおして何かを試している様
ですが結局何をされているのでしょうか?そろそろプロジェクトの内容を明かしていただけると
皆さん幸せになれるかなと思うのですが?

こん!<=^・^=>

mua 2002/11/26(火) 00:54:14
[[解決]]
> デバッグモードやリリースモード、ダイナミックやスタティックリンクを変更すると、
> なぜ、エラーが出てきたり、実行結果が変わったりするのでしょうか。
いろいろ試してみましたところ、ソースに根本的なエラーがありました。
ビルドをしたときはエラー数は0で、教えてもらえませんでした。
デバッグしたときに、エラーを発見できました。
あと、警告レベルを4にして、警告を全て対処いたしましたところ、
デバッグモードやリリースモード、ダイナミックやスタティックリンクに関係なく、
実行ファイルを無事に実行することができました。

アドバイスくださった皆様には、感謝いたします。

こん! 2002/11/26(火) 01:38:20
> いろいろ試してみましたところ、ソースに根本的なエラーがありました。

 出来ましたらその具体的な内容も教えていただけると後々同じ状況になった方の道標となれる
かも。

こん!<=^・^=>

古いスレッドには追加発言できません。