WSAStartupの複数回呼び出し(異なるバージョンで)

[戻る]
すずめ [E-Mail] 2002/12/26(木) 20:04:54
2000 Professional で、VC++6.0を使用しております。

WSAStartupを複数回呼び出しする事ができるらしいのですが
その場合、異なるバージョン番号を指定すると一体、何が有効になるのでしょうか

例えば 1.1 2.0 を呼んだ場合、2.0は、1.1を包含しているという理由で
2.0が走るのでしょうか?

ライブラリごとに、WSAStartupが呼ばれるので、このような問題に直面していますが
どなたか、詳しい方、よろしくお願いします。

dairygoods 2002/12/27(金) 11:30:11
WSAStartupは、WinSock DLLが指定したバージョン以上かどうかを調べるもので、
指定したバージョンでの動作に限定してしまうものではないと思いますが。

すずめ [E-Mail] 2002/12/27(金) 19:38:17
回答、ありがとうございます。

という事は、結局 マシンに乗っているWinsockのバージョンが働く
と、いう理解でよろしいのでしょうか?

古いスレッドには追加発言できません。