ツールチップ

[戻る]
kazu 2003/09/06(土) 00:47:05
ボタンにツールチップをつけたんですが、ボタンを押すとツールチップが
表示されなくなってしまいます。
どうしてでしょうか?

OSはXPでVS.NET 2003です。

LG 2003/09/06(土) 10:06:52
ボタンを押すとツールチップが表示されなくなるように作ったから

としか答えられません。

2003/09/06(土) 11:58:39
マルチポスト

kazu 2003/09/06(土) 22:47:23
マルチポスト??

MEではちゃんと表示されるんですが、、、XPではボタンを押すと消えてしまうんです。
http://msdn.microsoft.com/library/default.asp?url=/library/en-
us/shellcc/platform/commctls/tooltip/usingtooltips.asp
をさんこうにして作ったんですが、、、

とおりすがり 2003/09/07(日) 00:22:23
じゃあ、マルチポストを検索してください。

kazu 2003/09/07(日) 00:32:19
このサイトをマルチポストで検索しても参考になりそうな記述は見つからなかったので
すが……

とおりすがり 2003/09/07(日) 03:28:49
わざとそういう発言をしてるとしか思えないが…
このサイトの検索(ラウンジの全トピックからってやつ)でマルチポストを検索しても、
ちゃんと出ますよ。

kazu 2003/09/07(日) 05:19:41
マルチポストとツールチップで検索したところ以下のものがヒットしました
http://rararahp.cool.ne.jp/cgi-bin/lng/vc/vclng.cgi?print+200207/02070031.txt
しかしこれを参照して解決出来るとは思えないのですが?

僕が何かを勘違いしている??

とおりすがり2 2003/09/07(日) 18:02:31
結局、マルチポストの意味はわかったのですか?

kazu 2003/09/07(日) 20:05:45
マルチポストの意味はもとから知っていますが、、、?

PATIO 2003/09/08(月) 10:44:14
では、下の「使用上の注意」をお読みになりましたか?

kazu 2003/09/08(月) 11:16:58
>>■ マルチポストについて
のことですか?

確かに「る」さんは「マルチポスト」と発言していますが、、、
ひょっとして皆さんは僕がマルチポストをしていると思っているってことですか??

PATIO 2003/09/08(月) 11:37:05
おお、るさんがポインタを示していないので変だと思ったのですが、
もしかして、るさんの勘違いかな?
少なくとも、るさんはそう思っているようですね。

MEの環境が無いのでなんともいえないのですけれど、
ツールチップの表示対称にしているボタンを押すと
ツールチップが消えると言う話ですよね。
消えるとどうまずいのかが良く変わらないのですけれど。
というか、ツールチップが表示されるタイプのソフトで
XP上で試してみても、ボタン上にカーソルがくれば、
ツールチップが表示されて、押すとツールチップは消えます。
この動きが普通のような気がしますけれど。

kazu 2003/09/08(月) 11:54:20
PATIOさん、返事ありがとうございます!!

僕はIEで確かめたのですが、他のツールチップを表示するとまた表示
されるようになるんですね。

僕はクリックされたらツールチップを削除して、またツールチップを
作り直すというやり方でクリックされても再度ちゃんと表示されるよ
うにしていたのですが、IEがこれと同じことをやっているとは思えな
くて質問させて頂きました。

でもIEで、クリックして表示されなくなるってことはこれがXPの標準
の仕様ということになるのですかねぇ。
IEではツールチップが表示されるときに他のツールチップ全てを僕み
たいにリセットしていると考えると。

ただ一度クリックされたくらいで消えてしまうのはユーザーに不親切
だと思うのでXPはどうなってるんだろう?
視覚効果の設定でも「クリックしたツールチップは表示しない」なん
ていう設定はありませんですし。

謎ですね(涙)

kazu 2003/09/08(月) 11:59:17
あれ?
あ、ちょっと違いますね、僕の説明不足でした。

ボタンを押すと、以後そのボタン上にカーソルを持って行ってもツールチップ
が表示されなくなるという問題です。

ボタンを押すと表示中のツールチップが消えるのは問題ありませんが、以後そ
のボタン上にカーソルを持って行ってもツールチップが表示されないというの
が問題です。

説明不足申し訳ありません。

PATIO 2003/09/08(月) 11:59:48
もしかして、一度クリックしてしまうと他のツールチップが表示されるまで
マウスカーソルを持っていっても二度と表示されないという話??
そんな現象はおきてないなぁ。
少なくとも自作のプログラムでは起こってません。
やり方が違うとは思えないけれど。

kazu 2003/09/08(月) 12:05:33
>一度クリックしてしまうと他のツールチップが表示されるまで
>マウスカーソルを持っていっても二度と表示されないという話??

あ、すいませんこれはIEでの話です。

要するに起きている問題は、
ボタンをクリックすると、以後そのボタン上にマウスを持って行っても
ツールチップが表示されないということです。
MEではボタンをクリックしてもそのボタンのツールチップは有効になっ
ていて、再びそのボタンの上にマウスを持って行ってもツールチップは
表示されるのですが、XPではボタンをクリックするとそのボタンのツール
チップが何故か以後マウスを持って行っても表示されなくなるんです。

PATIO 2003/09/08(月) 12:09:22
それってボタンの親ウインドウのフォーカスが他のウインドウに移動してませんか?
ウインドウのフォーカスがないとツールチップは表示されないはずです。
というか、そのくらいしか思いつかないです。
私が自作しているプログラムではそういった現象は起きていません。
ボタンを押した結果フォーカスが移動するようならありえる話だと思いますけれど。

kazu 2003/09/09(火) 11:36:50
フォーカスの問題ではなさそうです、、、

コードを検索して自分のと比較してみます

PATIO 2003/09/10(水) 10:19:46
いまさらながらあげておられたMSのHPを参照してきましたが、
kazuさんの実装と私の実装は若干違いがあるみたいですね。
私の場合は、VC6でやっていますが、MFCをつかって簡便にやっています。
今のところ、特に問題は出ていません。
私が参考にしていたHPがなくなってしまっているので
似たような例を挙げておきます。

http://www.alpha-net.ne.jp/users2/uk413/vc/VCT_TOOLTIP.html

MFCを使わないのであれば、あまり参考にならないかもしれませんね。

古いスレッドには追加発言できません。