プログラム '[748] test.exe: ネイティブ' はコード 0 (0x0) で終了しました

[戻る]
やすたろう 2005/09/17(土) 10:43:19
Visual Studio2003環境(C++.net)から、作成済みプロジェクト(外部デバイスとの通信
プログラム)をデバッグ→開始すると、”プログラム '[748] test.exe: ネイティブ' 
はコード 0 (0x0) で終了しました”というメッセージが表示され、何も起こりません。
本来このプログラムはキーボードのESCキーを押すまでは外部デバイスとの通信を継続す
るはずなのですが・・・。何故このような現象が起こるのでしょうか?お手数ですが、
思い当たる方がいれば是非、ご助言下さいませ。尚、このプロジェクトをビルドしてみ
ましたがエラーはでませんでした。

RAPT 2005/09/17(土) 10:58:28
何らかの条件により、プロセス開始→終了しているだけでしょう。
トレース実行してどういった経路で実行されているか確認すると良いかと思われます。

RAPT 2005/09/17(土) 11:33:00
マルチ投稿ですね。
http://forums.belution.com/ja/cpp/000/041/99s.shtml

Ban 2005/09/17(土) 11:33:50
test.exe がまともな作りなら、終了コードゼロは正常終了です。

どこかロジックのミスがあって、処理を抜けてるのでは?
 例:デバイスが開けていない、とか

ちなみに、ビルドしてエラーが出ないことは単なる前提条件であって、
バグの有無とは関係ありません。デバッグしてください。

# 「マルチポスト」は回答者の心象を損ねる可能性があります。
# http://hpcgi1.nifty.com/MADIA/Vcbbs/wwwlng.cgi?print+200509/05090042.txt
# 両掲示板で回答者をよく見れば、かなり重複しているでしょう。
# 仮に閲覧者が増えても、回答者の心象を損ねたら、質問者にとってもマイナスでは。

やすたろう 2005/09/17(土) 12:02:58
>test.exe がまともな作りなら、終了コードゼロは正常終了です。
>どこかロジックのミスがあって、処理を抜けてるのでは?
 例:デバイスが開けていない、とか

ご回答有り難うございます。上記確認してみます。ご参考までに現在出力されるメッセ
ージを下記に記載します。
お気づきの点があればご指摘下さいませ。

test.exe': 'c:\Documents and Settings\既定\デスクトップ\test\Debug\test.exe' を
読み込みました。シンボルが読み込まれました。
'test.exe': 'C:\WINDOWS\system32\ntdll.dll' を読み込みました。シンボルが読み込
まれていません。
'test.exe': 'C:\WINDOWS\system32\kernel32.dll' を読み込みました。シンボルが読み
込まれていません。
'test.exe': 'C:\WINDOWS\system32\hil.dll' を読み込みました。シンボルが読み込ま
れていません。
'test.exe': 'C:\WINDOWS\system32\advapi32.dll' を読み込みました。シンボルが読み
込まれていません。
'test.exe': 'C:\WINDOWS\system32\rpcrt4.dll' を読み込みました。シンボルが読み込
まれていません。
'test.exe': 'C:\Program Files\Quanser\Quanser HIL SDK\test.dll' を読み込みまし
た。シンボルが読み込まれていません。
'test.exe': 'C:\WINDOWS\system32\setupapi.dll' を読み込みました。シンボルが読み
込まれていません。
'test.exe': 'C:\WINDOWS\system32\msvcrt.dll' を読み込みました。シンボルが読み込
まれていません。
'test.exe': 'C:\WINDOWS\system32\gdi32.dll' を読み込みました。シンボルが読み込
まれていません。
'test.exe': 'C:\WINDOWS\system32\user32.dll' を読み込みました。シンボルが読み込
まれていません。
'test.exe': 'C:\WINDOWS\system32\imm32.dll' を読み込みました。シンボルが読み込
まれていません。
'test.exe': 'C:\WINDOWS\system32\lpk.dll' を読み込みました。シンボルが読み込ま
れていません。
'test.exe': 'C:\WINDOWS\system32\usp10.dll' を読み込みました。シンボルが読み込
まれていません。
'test.exe': 'C:\Program Files\Quanser\Quanser HIL SDK\test.dll' をアンロード
'test.exe': 'C:\WINDOWS\system32\setupapi.dll' をアンロード
'test.exe': 'C:\WINDOWS\system32\msvcrt.dll' をアンロード
プログラム '[320] test.exe: ネイティブ' はコード 0 (0x0) で終了しました。

Ban 2005/09/17(土) 15:47:19
シンボルの読み出しは、通常の場合無視してかまいません。
アンロードの通知も、たいてい無視していいでしょう。
プログラムが正常に実行され、正常に終了したことがわかります。
逆にいうと、この問題に対して、それ以上のことはほぼわかりません。

プログラムは思ったようにではなく書かれたように動くので、
単に やすたろう さんの思惑と違うだけで、正常に処理を終了しているということです。

それ以上は自身で「ステップ実行」なり「トレース」なりしてください。
デバイスやソースすら示さずに質問して回答がつく類のものではないように思います。


# 私からは以上です。がんばってください。

やすたろう 2005/09/18(日) 10:14:40
[[解決]]
Banさんへ
有り難うございました。

επιστημη 2005/09/19(月) 01:37:05
解決したのなら、他の投稿先のスレッドもきちんと'けり'を付けておいてください。
# それをやんないのがマルチポストが嫌われる一因です。

古いスレッドには追加発言できません。