ブレークポイントがヒットしない

[戻る]
TERA 2006/07/15(土) 13:04:42
VisualStudio 2005 Professional で開発をしております。

プログラムを書いていたら、
いつのまにかブレークポイントがうまく動作しなくなりました。
必ず通る箇所にブレークポイントを置き、プログラムを実行させた途端に、
ブレークポイントの赤く塗られた●マークが、 ただの赤線の○マークになり、○の中に
「!」が表示されるようになりました。

その赤線の○のブレークポイントにマウスカーソルを持っていくと、
「ブレークポイントは、現在の設定ではヒットしません。
 ソースコード が元のバージョンと異なります。」 と表示されます。

ブレークポイントにちゃんと止まらないので、困っています。

やってみたことは「ソリューションのリビルド」と
「ソリューションのクリーン」と手動での.pdbファイルの削除です。
でもいくらやっても結果は同じでした。


なにか解決策がありましたら、アドバイスよろしくお願いします。。

ITO 2006/07/15(土) 13:36:27
VC 2005は変わっているかも知れませんが、
1. *.APS、*.ncbのファイルを他のフォルダに移動する。
2. Release、DebugのDLL関係のファイル以外をすべて削除する。
3. 必要に応じてCドライブ、Dドライブのスキャンディスクをかける。
4. 再起動後、再コンパイルする。
5. 異常が起きたら*.APS、*.ncbのファイルを元に戻す。
でどうでしょうか。

ITO 2006/07/15(土) 13:38:27
あっと、Dドライブとはソースファイルのあるドライブです。

TERA 2006/07/15(土) 14:58:44
ITOさん

アドバイスありがとうございます。
1度、スキャンディスクをせずに、
教えて頂いたとおりにやってみましたが、何も変わりませんでした・・・。

いまスキャンディスクしております。

2006/07/15(土) 17:13:57
テンプレートの中にブレークポイント張ろうとしてるなら…

2005は知らないけれど、2003でそうなった気がする。
型が確定できないからだろうけど…
その場合は呼ぶ前にブレークポイント張って止めてました。

ITO 2006/07/15(土) 18:28:03
そのブレークポイントを張ろうとしている場所にカーソルを移して、
右クリック→「カーソル行の前まで実行」でも駄目ですか?

TERA 2006/07/15(土) 19:16:52
[[解決]]
>・・・さん

アドバイスありがとうございます。
テンプレートは使用していないので、違うかと思われます。
今朝まではちゃんとブレークポイントが止まっていたのですが・・・

>ITOさん

スキャンディスクしましたが結果は同じでした。
「カーソルの行の前まで実行」をしてみましたが、やはりだめでした。


オプション→デバッグ→全般 を開き、
「元のバージョンと完全に一致するソースファイルを必要とする」の
チェックをはずすと、一応ブレークポイントにとまることができました。

でもこれは、根本的な解決ではありませんよね・・。
よく調べてみたら、同じような不具合の方が大勢いらっしゃるようです。

一応、ここで「解決」ということにしようと思います。
お2人とも、助言していただいて、どうもありがとうございました。

ITO 2006/07/15(土) 19:43:33
>オプション→デバッグ→全般 を開き、
>「元のバージョンと完全に一致するソースファイルを必要とする」の
>チェックをはずすと、一応ブレークポイントにとまることができました。

正解みたいです。

http://msdn2.microsoft.com/ja-JP/library/z51bbsk8.aspx

http://www.langedge.jp/blog/?&blogid=1&archive=2006-6-14

TERA 2006/07/15(土) 21:57:04
>ITOさん

詳しい情報をありがとうございました。
そこまで調べていただけて、嬉しいです。
ありがとうございます。

古いスレッドには追加発言できません。